OpenStack - Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-keystone' returned 1: Error: Package: python2-pyngus-2.3.0-1.el7.noarch


This topic we are installing openstack train /queen version in CentOS7 using packstack, but we are getting below error during the installation.

ERROR : 

Error appeared during Puppet run: 10.0.2.15_controller.pp
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-keystone' returned 1: Error: Package: python2-pyngus-2.3.0-1.el7.noarch (epel)



Cases:

openstack-keystone package require dependent  python2-pyngus-x.x.x.-1.el7.noarch and its trying to install latest version from EPEL repository and in openstack repository it has old version. 

  Requires: python2-qpid-proton >= 0.28.0
           Available: python2-qpid-proton-0.26.0-2.el7.x86_64 (openstack-train)



Checked Rpm version 


Solution:

Disable EPEL and Other repository  which is not require to install openstack

cd /etc/yum.repo.d
vi epel.repo

We can set enabled=0 for disable the repository 


Enjoy!! Now you can try again  hope it will installed 


Thanks you !! 
 I hope this topic gave you all the information you needed. If you have any further questions or would like more detailed directions feel free to contact us using any of the following sources.We look forward to talking to you.

No comments

Powered by Blogger.